Degraded Performance

Incident Report for Cars and Bids

Resolved

AWS has declared their issues resolved as of 1 AM PT today, 2023-09-19
Posted Sep 19, 2023 - 06:53 PDT

Identified

Due to ongoing AWS issues, we have extended today's auctions to tomorrow to ensure that all bidders have an opportunity to bid.
Posted Sep 18, 2023 - 13:18 PDT
This incident affected: Servers (Compute).